Ao realizar a atualização para a versão 22 do Ubuntu, talvez você possa enfrentar alguns problemas com a atualização do PHP, devido ao PPA estar definido apontando para a versão anterior

Para deixar o Ubuntu pronto para atualizar o PHP para as versões corretas, basta seguir os seguintes passos:

Remova os PPAs anteriores referente a ondrej/php

cd /etc/apt/sources.list.d
sudo rm ondrej-ubuntu-php-impish.list*

ou

sudo rm ondrej-ubuntu-php*

Em seguida, adicione o repositório ondrej/php

sudo apt install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt upgrade